Критическая уязвимость в генераторе случайных чисел GnuPG и Libgcrypt

Разработчики пакета GnuPG объявили о выявлении критической уязвимости в библиотеке Libgcrypt, предоставляющей компоненты, лежащие в основе механизмов шифрования, применяемых в GnuPG. Уязвимость присутствует в функции смешивании энтропии генератора псевдослучайных чисел, используемом в Libgcrypt и GnuPG, и позволяет предсказать следующие 20 байт последовательности, получив 580 байт от генератора. Ошибка была допущена на раннем этапе разработки ещё в 1998 году, поэтому проблема присутствует во всех версиях GnuPG и Libgcrypt, выпущенных до 17 августа 2016 года.

Анализ возможных последствий уязвимости показал, что она не влияет на надёжность созданных в GnuPG ключей RSA. Что касается ключей DSA и Elgamal, то возможность предсказания закрытого ключа по открытой информации оценивается как маловероятная. Причин для срочной замены ключей нет, но влияние проблемы на надёжность ключей ещё требует более глубокого изучения.

Для RSA отсутствие влияния проблемы связано с тем, что при генерации RSA-ключа в GPG создаётся два ключа - для первого 4096-разрядного ключа RSA использует 512 байт случайных чисел, а утечка приходятся на второй вспомогательный ключ, 20 байт случайных данных для которого могут быть предсказаны из последовательности для первого ключа. Так как первым генерируется первичный ключ, от которого зависит безопасность, предсказуемые 20 байт не представляют угрозы. Для 2048-разрядных ключей RSA оба ключа укладываются в надёжные 580 байт случайных данных. При создании ключей DSA+Elgamal читается как минимум 1140 байт случайных чисел, поэтому с ними не всё так однозначно.

Проблема устранена в Libgcrypt 1.7.3, 1.6.6 и 1.5.6 (используется в GnuPG 2), а также в GnuPG 1.4.21. Обновления пакетов в дистрибутивах пока не выпущены (Ubuntu, Debian, RHEL, FreeBSD, CentOS, Fedora, SUSE). В качестве идентификатора уязвимости указан CVE-2016-6316, но судя по всему допущена ошибка, так как CVE-2016-6316 уже ранее был привязан к уязвимости в Ruby on Rails.

Дополнение: Назван корректный CVE-идентификатор - CVE-2016-6313.

08/17/2016 20:57:17
0

комментарии (0)